utf 8 – I’m getting linker error in visual studio 2017 after i set console page code 65001

0
5

first, sorry for my English because i don’t English well. 🙁

when consol page code(Exactly, HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlNlsCodePageOEMCP)is ‘949’, i havn’t any probrem about use visual studio 2017

but i can’t see my language on the console when console page code is ‘949’, so i had to change consol page code to ‘65001’

after i changed consol page code to ‘65001’, i tried debug my code, and i god linker error, even what i do.

i know if i change again console page code to ‘949’, this probrem will be solve.

but this way is make me can’t see my language on the console again.

i found for other way for 2 weeks, but i have no idea even now.

so i’m not good at English, but i have to raise questions here.

The introduction was long… here is my code, and error log.

code :

#include <stdio.h>

int main()
{
    return 0;
}

error log :

1>------ build start, project : *name*, Configuration: Debug Win32 ------
1>LINK : C:Users*name*sourcerepos*name*Debug*name*.exe is not found or not 
built by the last incremental link; performing full link
1>
1>LINK : fatal error LNK1000: Internal error during IMAGE::BuildImage
1>
1>  Version 14.16.27026.1
1>
1>  ExceptionCode            = C0000005
1>  ExceptionFlags           = 00000000
1>  ExceptionAddress         = 66BEE44D (66BE0000) "C:Program Files(x86)MSBuild15.0FileTrackerFileTracker32.dll"
1>  NumberParameters         = 00000002
1>  ExceptionInformation[ 0] = 00000000
1>  ExceptionInformation[ 1] = 00000000
1>
1>CONTEXT:
1>  Eax    = 00000000  Esp    = 005BBA40
1>  Ebx    = 00160A42  Ebp    = 005BBAC4
1>  Ecx    = 31DE83F8  Esi    = 00000000
1>  Edx    = 00000000  Edi    = 00000000
1>  Eip    = 66BEE44D  EFlags = 00010246
1>  SegCs  = 00000023  SegDs  = 0000002B
1>  SegSs  = 0000002B  SegEs  = 0000002B
1>  SegFs  = 00000053  SegGs  = 0000002B
1>  Dr0    = 00000000  Dr3    = 00000000
1>  Dr1    = 00000000  Dr6    = 00000000
1>  Dr2    = 00000000  Dr7    = 00000000
1>"*name*.vcxproj" project builded. - failed

if i doing wrong about anything(this site’s rule, lack of explanation… etc.), please say to me, i’ll fix anything for find a way.

thanks for read.

LEAVE A REPLY

Please enter your comment!
Please enter your name here